HDU--1798--贪心

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5

思路:1.扣除分数大的先做;2.扣除分数相同,先截止的先做;

3.做一件事的时候,从截止时间开始向第一天遍历,如果当天没有被作业占据则标记为占据。做这件事的日期越大越好.

#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#define MAX 1010
using namespace std;
int V[MAX];
int E[MAX];
bool t[MAX];
int order[MAX];
bool cmpA (int a,int b){
    if(V[a]>V[b]){
        return 1;
    }
    else if(V[a]==V[b]&&E[a]<E[b]){
        return 0;
    }
    else 
        return 0;
}
int main(){
    int T;
    while(~scanf("%d",&T)){
        for(int i=0; i<T;++i){
            memset(t,0,MAX*sizeof(bool));
            int N;
            int All=0;
            int ans=0;
            scanf("%d",&N);
            for(int j=0;j<N;++j)
                scanf("%d",&E[j]);
            for(int j=0;j<N;++j){
                scanf("%d",&V[j]);
                All=All+V[j];
                order[j]=j;
            }
            sort(order,order+N,cmpA);
            for(int j=0;j<N;++j){
                int event=order[j];
                bool flag=0;
                for (int k=E[event];k>=1;k--){
                    if(!t[k]){
                        ans=ans+V[event];
                        t[k]=1;
                        flag=1;
                    }
                    if(flag) break;
                }
            }
            cout<<All-ans << endl;
        }
    }
}
发布了150 篇原创文章 · 获赞 73 · 访问量 6564

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104353780