杭电oj刷题(2092)

整数解

题目描述:
有二个整数,它们加起来等于某个整数,乘起来又等于另一个整数,它们到底是真还是假,也就是这种整数到底存不存在,实在有点吃不准,你能快速回答吗?看来只能通过编程。
例如:
x + y = 9,x * y = 15 ? 找不到这样的整数x和y
1+4=5,1*4=4,所以,加起来等于5,乘起来等于4的二个整数为1和4
7+(-8)=-1,7*(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8

Input

输入数据为成对出现的整数n,m(-10000<n,m<10000),它们分别表示整数的和与积,如果两者都为0,则输入结束。

Output

只需要对于每个n和m,输出“Yes”或者“No”,明确有还是没有这种整数就行了。

Sample Input

9 15 
5 4 
1 -56 
0 0

Sample Output

No 
Yes 
Yes

分析:

∵x + y = n
∴y = n - x
∵xy = m
∴(n - x) * x = m
∴x*x - nx + m = 0
t=n*n-4*m

通过答案:

#include<stdio.h>
#include<math.h>
int main(){
	int n,m,t,t1;
	while(scanf("%d %d",&n,&m)!=EOF){
		if(n==0&&m==0)break;
		t=n*n-4*m;       //△=b*b-4*a*c 
		t1=(int)sqrt(t);    
		if(t>=0&&t==t1*t1){    //△>=0表示方程有解并且解都为整数 (关键)
			printf("Yes\n");
		}else{
			printf("No\n");
		}
	}
	return 0;
} 
发布了76 篇原创文章 · 获赞 3 · 访问量 1850

猜你喜欢

转载自blog.csdn.net/ZhangShaoYan111/article/details/104374085
今日推荐