杭电Oj刷题(2052)

Picture

题目描述:

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input

3 2

Sample Output

+---+ 
|   |
|   | 
+---+

通过答案:

#include <stdio.h>
int main(){
    int w,h,i,j;
    while(scanf("%d%d",&w,&h)!=EOF){
    	printf("+");
    	for(i=0;i<w;i++){
    		printf("-");
		}
		printf("+\n");
		
		for(j=0;j<h;j++){
			printf("|");
			for(i=0;i<w;i++){
				printf(" ");
			}
			printf("|");
			printf("\n");
		}
		printf("+");
    	for(i=0;i<w;i++){
    		printf("-");
		}
		printf("+\n\n");      //注意:最后要空一行 
        
    }
	return 0;     
}
发布了76 篇原创文章 · 获赞 3 · 访问量 1875

猜你喜欢

转载自blog.csdn.net/ZhangShaoYan111/article/details/104268400