CD//UVA - 624//记录路径的01背包

CD//UVA - 624//记录路径的01背包


题目

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on
CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How
to choose tracks from CD to get most out of tape space and have as short unused space as possible.
Assumptions:
• number of tracks on the CD does not exceed 20
• no track is longer than N minutes
• tracks do not repeat
• length of each track is expressed as an integer number
• N is also integer
Program should find the set of tracks which fills the tape best and print it in the same sequence as
the tracks are stored on the CD
Input
Any number of lines. Each one contains value N, (after space) number of tracks and durations of the
tracks. For example from first line in sample data: N = 5, number of tracks=3, first track lasts for 1
minute, second one 3 minutes, next one 4 minutes
Output
Set of tracks (and durations) which are the correct solutions and string ‘sum:’ and sum of duration
times.
Sample Input
5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2
Sample Output
1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45
题意
给你一个n时间限制的cd,有m首曲子,接下来是m首曲子的时间,最后选出的曲子总时间尽可能大,输出对应曲子的时间已经总时间。
链接:https://vjudge.net/contest/349029#problem/A

思路

记录路径的01背包,模板题

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;

int f[10005],v[30],path[30][10005];//f为dp数组
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(f,0,sizeof(f));
		memset(path,0,sizeof(path));
        for(int i=0;i<m;i++)
            scanf("%d",&v[i]);
        for(int i=0;i<m;i++){                   //01背包模板
            for(int j=n;j>=v[i];j--){
                if(f[j-v[i]]+v[i]>=f[j]){
                    path[i][j]=1;               //记录路径
                    f[j]=f[j-v[i]]+v[i];
                }
            }
        }
        int p=n;
        for(int i=m-1;i>=0&&p>=0;i--){                //输出路径
            if(path[i][p]==1){
                printf("%d ",v[i]);
                p-=v[i];
            }
        }
        printf("sum:%d\n",f[n]);
    }
    return 0;
}

注意

发布了33 篇原创文章 · 获赞 9 · 访问量 2084

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104144116