PAT Advanced 1070 Mooncake (25) [贪⼼算法]

题目

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the regions culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of diferent kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

题目分析

已知不同种类月饼的库存,总价格,市场需求量,求最大利润

解题思路

  1. 贪心思想:依次获取单位价格最贵的月饼
  2. 结构体moon,存储月饼的库存,总价格,单位价格(输入总价格时预处理,减少一次遍历)
  3. 按照单位价格降序排序,依次获取,直到达到市场需求量

Code

Code 01

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct moon {
    double w; // total weight (in thousand tons)
    double p; // total price (in billion yuan)
    double pp; // price per thousand ton
};
bool cmp(moon &m1,moon &m2) {
    return m1.pp>m2.pp;
}
int main(int argc, char * argv[]) {
    // 1 接收数据 
    int N,D;
    scanf("%d %d",&N,&D);
    vector<moon> vms(N); //存放月饼数据 
    for(int i=0; i<N; i++) scanf("%lf", &vms[i].w);
    for(int i=0; i<N; i++) {
        scanf("%lf", &vms[i].p);
        vms[i].pp = vms[i].p/vms[i].w; //计算每重量单位的价格 
    }
    // 2 按照单位价格高-低排序 
    sort(vms.begin(),vms.end(),cmp);
    // 3 求最大利润 
    double tp = 0.0;
    for(int i=0; i<N&&D>0; i++) {
        if(vms[i].w<D) {//如果当前月饼种类的重量小于需求剩余数,全部销售 
            D=D-vms[i].w;
            tp+=vms[i].p;
        } else { //如果当前月饼种类的重量大于需求剩余数,按照单位价计算剩余需求重量 
            tp+=D*vms[i].pp;
            D=0;
        }
    }
    printf("%.2f", tp);
}


猜你喜欢

转载自www.cnblogs.com/houzm/p/12245407.html
今日推荐