PAT-A 1070 Mooncake (25)(25 分)简单贪心

https://pintia.cn/problem-sets/994805342720868352/problems/994805399578853376

1070 Mooncake (25)(25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

思路及关键点:

扫描二维码关注公众号,回复: 2843668 查看本文章

1、使用贪心算法,把月饼按照其单价=总售价/存储量 进行排序,优先卖出单价高的月饼。

2、如果该种月饼的销售量<=市场最大需求量,那么更新 市场最大需求量、总收益:

     市场最大需求量=市场最大需求量-该种月饼的销售量;

    总收益=总收益+该种月饼的总售价

3、如果该种月饼的销售量>市场最大需求量,那么更新 总收益:

    总收益=总收益+该种月饼的单价*市场最大需求量;

AC代码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int nmax=1000+10;
struct mooncake{
	double store;//存储量 
	double sell; //总售价 
	double price;//单价 
}cake[nmax];
 
bool cmp(mooncake a,mooncake b){
	return a.price>b.price; //按照单价从高到低排序 
}
int main(int argc, char** argv) {
	int n;//月饼的种类数 
	double d;//市场最大需求量
	while(cin>>n>>d){
		for(int i=0;i<n;i++){
			cin>>cake[i].store; 
		}
		for(int i=0;i<n;i++){
			cin>>cake[i].sell;
			cake[i].price=cake[i].sell/cake[i].store;//计算出单价 
		}
		sort(cake,cake+n,cmp);
		double ans=0;//最大收益
		for(int i=0;i<n;i++){
			if(cake[i].store<=d){
				d-=cake[i].store;
				ans+=cake[i].sell;
			}else{//cake[i].store>d
				ans+=cake[i].price*d;
				break;
			}
		}
		//cout<<ans<<endl; 
		printf("%.2f\n",ans); 
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qian2213762498/article/details/81806409
今日推荐