HDU1098 Ignatius's puzzle (数学归纳法)

Description:

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that: f ( x ) = 5 x 13 + 13 x 5 + k a x f(x)=5*x^{13}+13*x^5+k*a*x ,input a nonegative integer k ( k < 10000 ) k(k<10000) ,to find the minimal nonegative integer a,make the arbitrary integer x x , 65 f ( x ) 65|f(x)

if no exists that a,then print " n o " . "no".

Input

The input contains several test cases. Each test case consists of a nonegative integer k k , More details in the Sample Input.

Output

The output contains a string “ n o no ”,if you can’t find a,or you should output a line contains the a a .More details in the Sample Output.

Sample Input

11
100
9999

Sample Output

22
no
43

题意:

给定一个方程式 f ( x ) = 5 x 13 + 13 x 5 + k a x f(x)=5*x^{13}+13*x^5+k*a*x ,给定一个非负整数k,求能不能找到一个尽量小的非负整数 a a ,使得上述方程式中的 x x 任意取值,结果都能被 65 65 整除,如果有,输出 a a 的值,否则输出 n o no
我们采用数学归纳法,假设 a a 对于 f ( x ) f(x) 成立的话那么对于 f ( x + 1 ) f(x+1) 也一定成立, f ( x ) = 5 x 13 + 13 x 5 + k a x f(x)=5*x^{13}+13*x^5+k*a*x

= 5 ( x + 0 ) 13 + 13 ( x + 0 ) 5 + k a ( x + 0 ) =5*(x+0)^{13}+13*(x+0)^5+k*a*(x+0)

f ( x + 1 ) = 5 ( x + 1 ) 13 + 13 ( x + 1 ) 5 + k a ( x + 1 ) f(x+1)=5*(x+1)^{13}+13*(x+1)^5+k*a*(x+1)

采用二项式定理, f ( x + 1 ) f ( x ) = 18 + k a f(x+1)-f(x)=18 + k * a 如果是的要求成立的话那么 65 ( f ( x + 1 ) f ( x ) ) 65|(f(x+1)-f(x)) 即: 65 ( 18 + k a ) 65|(18 + k * a) , 所以只要暴力求解就行了,我们输出一部分就会发现 a a 都是小于 70 70

AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
    int ret = 0, sgn = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9')
    {
        if (ch == '-')
            sgn = -1;
        ch = getchar();
    }
    while (ch >= '0' && ch <= '9')
    {
        ret = ret * 10 + ch - '0';
        ch = getchar();
    }
    return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
    if (a > 9)
        Out(a / 10);
    putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
    if (a >= mod)
        a = a % mod + mod;
    ll ans = 1;
    while (b)
    {
        if (b & 1)
        {
            ans = ans * a;
            if (ans >= mod)
                ans = ans % mod + mod;
        }
        a *= a;
        if (a >= mod)
            a = a % mod + mod;
        b >>= 1;
    }
    return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
    return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int g = exgcd(b, a % b, x, y);
    int t = x;
    x = y;
    y = t - a / b * y;
    return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
    int d, x, y;
    d = exgcd(a, p, x, y);
    if (d == 1)
        return (x % p + p) % p;
    else
        return -1;
}

///中国剩余定理模板0
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
    int M = 1, y, x = 0;
    for (int i = 0; i < n; ++i) //算出它们累乘的结果
        M *= a[i];
    for (int i = 0; i < n; ++i)
    {
        int w = M / a[i];
        int tx = 0;
        int t = exgcd(w, a[i], tx, y); //计算逆元
        x = (x + w * (b[i] / t) * x) % M;
    }
    return (x + M) % M;
}

int main()
{
    int k;
    while (~sd(k))
    {
        int ans;
        bool flag = 0;
        rep(i, 0, 70)
        {
            if ((18 + k * i) % 65 == 0)
            {
                flag = 1;
                ans = i;
                break;
            }
        }
        if (!flag)
            puts("no");
        else
            pd(ans);
    }
    return 0;
}
发布了611 篇原创文章 · 获赞 390 · 访问量 20万+

猜你喜欢

转载自blog.csdn.net/qq_43627087/article/details/104094723
今日推荐