Puzzle

A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:

  1. The square above the empty position moves.
  2. The square to the right of the empty position moves.
  3. The square to the right of the empty position moves.
  4. The square below the empty position moves.
  5. The square below the empty position moves.
  6. The square to the left of the empty position moves.
    Write a program to display resulting frames given their initial configurations and sequences of moves.
    Input
    Input for your program consists of several puzzles. Each is described by its initial configuration and
    the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
    configuration. Subsequent lines give the sequence of moves.
    The first line of the frame display corresponds to the top line of squares in the puzzle. The other
    lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
    exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
    square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
    The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
    moves into the empty position. A denotes that the square above the empty position moves; B denotes
    that the square below the empty position moves; L denotes that the square to the left of the empty
    position moves; R denotes that the square to the right of the empty position moves. It is possible that
    there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
    occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
    over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
    Output
    Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
    the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
    configuration should be displayed.
    Format each line for a final configuration so that there is a single blank character between two
    adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
    position, then it will appear as a sequence of 3 blanks — one to separate it from the square to the left,
    one for the empty position itself, and one to separate it from the square to the right.
    Separate output from different puzzle records by one blank line.
    Note: The first record of the sample input corresponds to the puzzle illustrated above.
    Sample Input
    TRGSJ
    XDOKI
    M VLN
    WPABE
    UQHCF
    ARRBBL0
    ABCDE
    FGHIJ
    KLMNO
    PQRS
    TUVWX
    AAA
    LLLL0
    ABCDE
    FGHIJ
    KLMNO
    PQRS
    TUVWX
    AAAAABBRRRLL0
    Z
    Sample Output
    Puzzle #1:
    T R G S J
    X O K L I
    M D V B N
    W P A E
    U Q H C F
    Puzzle #2:
    A B C D
    F G H I E
    K L M N J
    P Q R S O
    T U V W X
    Puzzle #3:
    This puzzle has no final configuration.
    代码
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    int main()
    {
    char s[1007],square[10][10];
    int i,j,sr,sc,count1=0,flag,count,x,y,a,b;
    while(gets(square[0]))
    {
    flag=1;
    count=0;
    count1++;
    if(square[0][0]‘Z’)
    break;
    //判断是否停止
    for(i=1;i<5;i++)
    gets(square[i]);
    //读取其他行
    for(i=0;i<5;i++)
    for(j=0;j<5;j++)
    {
    if(square[i][j]<‘A’||square[i][j]>‘Z’)
    {sr=i;sc=j;break;}
    }
    //找到空格位置
    while((s[count]=getchar())!=‘0’)
    count++;
    s[count]=‘0’;
    getchar();
    //读取移动方式
    x=sr,y=sc;
    for(i=0;s[i];i++)
    {
    if(s[i]
    ‘A’)
    x=sr-1,y=sc;
    else if(s[i]‘B’)
    x=sr+1,y=sc;
    else if(s[i]
    ‘L’)
    x=sr,y=sc-1;
    else if(s[i]‘R’)
    x=sr,y=sc+1;
    if(x<0||x>4||y<0||y>4)
    {flag=0;break;}
    else{
    square[sr][sc]=square[x][y];
    square[x][y]=’ ';
    sr=x,sc=y;}
    }
    //判断移动
    if(count1!=1)
    printf("\n");
    printf(“Puzzle #%d:\n”,count1);
    if(flag
    1)
    for(a=0;a<5;a++)
    {
    for(b=0;b<5;b++)
    {
    if(b==0)
    printf("%c",square[a][0]);
    else
    printf(" %c",square[a][b]);
    }
    printf("\n");
    }
    else
    printf(“This puzzle has no final configuration.\n”);
    memset(square,0,sizeof(square));
    memset(s,0,sizeof(s));
    //重置
    }
    return 0;
    }

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/86257629