PAT甲级1004

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include<iostream>
#include<algorithm>
#include<vector>
#include<math.h>
using namespace std;

struct Node{
	int deep;
	vector<int> child;
}node[110];

int n, m, d[110] = { 0 }, h = 0;

void dfs(int root, int deep){
	node[root].deep = deep;
	h = max(h, deep);
	if (node[root].child.size() == 0){
		d[deep]++;
		return;
	}
	for (int i = 0; i < node[root].child.size(); i++)
		dfs(node[root].child[i], deep + 1);
}

int main(){
	scanf("%d %d", &n, &m);
	int no, k, x;
	for (int i = 0; i < m; i++){
		scanf("%d %d", &no, &k);
		for (int j = 0; j < k; j++){
			scanf("%d", &x);
			node[no].child.push_back(x);
		}
	}		
	dfs(1, 0);
	for (int i = 0; i <= h;i++)
	if (i != h)
		printf("%d ", d[i]);
	else
		printf("%d", d[i]);
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6043

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86769778
今日推荐