PAT甲级1076

1076 Forwards on Weibo (30 分)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
#include<bits/stdc++.h>
using namespace std;

const int Max = 1010;

struct Node{
	int v, deep;
};
int n, l, k;
vector<Node> follow[Max];
bool is[Max];

void bfs(int x){
	Node root;
	root.v = x;
	root.deep = 0;
	queue<Node> q;
	q.push(root);
	int num = 0;
	fill(is, is + Max, false);
	is[x] = true;
	while(!q.empty()){
		Node top = q.front();
		q.pop();
		x = top.v;
		for(int i = 0; i < follow[x].size(); i++){
			Node node = follow[x][i];
			node.deep = top.deep + 1;
			if(node.deep <= l && !is[node.v]){
				q.push(node);
				is[node.v] = true;
				num++;
			}
		}
	}
	printf("%d\n", num);
}

int main(){
	scanf("%d %d", &n, &l);
	int m, x;
	for(int i = 1; i <= n; i++){
		scanf("%d", &m);
		if(m != 0){
			Node node;
			node.v = i;
			for(int j = 0; j < m; j++){
				scanf("%d", &x);
				follow[x].push_back(node);
			}
		}
	}
	scanf("%d", &k);
	for(int i = 0; i < k; i++){
		scanf("%d", &x);
		bfs(x);
	}
	return 0;
}
发布了116 篇原创文章 · 获赞 7 · 访问量 6030

猜你喜欢

转载自blog.csdn.net/qq_40204582/article/details/86776141