PAT basic 1020 月饼 (25分) C++

一、题目描述

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:
3 20
18 15 10
75 72 45

输出样例:
94.50

二、代码

#define _CRT_SECURE_NO_WARNINGS
#include<stdlib.h>
#include<algorithm>
#include<iostream>
using namespace std;

typedef struct product {//这里是测试点2的问题所在
	//即库存量,总价应该为浮点类型
	float weight;
	float price;
	float ave;
	friend bool operator<(product a, product b) {
		return a.ave>b.ave;
	}
};

bool cmp(product a, product b)
{
	return a.ave > b.ave;
}

int main()
{
	int n,limit;
	cin >> n >> limit;
	product a[1001];
	for (int i = 0; i < n; i++)
	{
		cin >> a[i].weight;
	}
	for (int i = 0; i < n; i++)
	{
		cin>> a[i].price;
	}
	for (int i = 0; i < n; i++)
	{
		a[i].ave = 1.0*a[i].price / a[i].weight;
	}
	sort(a, a+n, cmp);
	/*for (int i = 0; i < n; i++)
	{
		cout<<a[i].ave<<" "<<a[i].price <<" "<<a[i].weight <<endl;
	}*/
	int left = limit;
	float sellprice = 0;
	for(int i=0;left>0&&i<n;i++)
	{
		if (left <= a[i].weight)
		{
			sellprice += 1.0*a[i].price / a[i].weight*left;
			printf("%.2f", sellprice);
			system("pause");
			return 0;
		}
		else 
		{
			sellprice += a[i].price;
			left -= a[i].weight;

		}

	}
	printf("%.2f", sellprice);
	system("pause");
	return 0;
}

三、运行结果

在这里插入图片描述

四、测试点2错误原因

在本题中,库存量、月饼价格均需要同时为浮点类型,不然测试2就会错误。

五、题目合集

点这里~

发布了42 篇原创文章 · 获赞 0 · 访问量 771

猜你喜欢

转载自blog.csdn.net/qq_44352065/article/details/103843055