判断出栈序列是否合法(c语言实现)

题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

代码

#include <stdio.h>  
#define maxn 1005  
int stack[maxn];  
int out[maxn];  
int check(int m,int n) 
{  
    int po=0,top=0;  
    for(int i=1;i<=n;i++)  
    {  
        for(int j=po+1;j<=out[i];j++)  
        {  
            po=j;  
            stack[top++]=j;  
			if(top>m) return 0; 	
        }  
        if(stack[--top]!=out[i])  
			return 0;  
    }  
    return 1;  
}  
int main()  
{  
    int m,n,k;  
    scanf("%d %d %d",&m,&n,&k);
	while(k--){
		for(int i=1;i<=n;i++){  
			scanf("%d",&out[i]);  
		}  
		if(check(m,n))  
			printf("YES\n");  
		else  
			printf("NO\n"); 	
	}
    return 0;  
}  

结果

在这里插入图片描述

发布了48 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_37551036/article/details/98188528