1138 Postorder Traversal (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3
#include<iostream>
#include<vector>

using namespace std;

struct node{
    
    int data;
    node * lchild;
    node * rchild;
};

node * creat_tree(vector<int> &pre, vector<int> &in, int pre_start, int pre_end, int in_start, int in_end){
    if(pre_start > pre_end || in_start > in_end){

        return NULL;
    }

    node * root = new node;
    int i;
    root ->data = pre[pre_start];
    for(i = 0; i < in.size(); i++){

        if(pre[pre_start] == in[i])
            break; 
    }
    root -> lchild = creat_tree(pre, in, pre_start + 1, pre_start + i - in_start, in_start, i - 1);
    root -> rchild = creat_tree(pre, in, pre_end + i + 1 - in_end, pre_end, i + 1, in_end);

 
    return root;
}
int flag = 0;
void post_order(node * tree){
    
    if(tree == NULL){
        return;
    }
    post_order(tree -> lchild);
    post_order(tree -> rchild);
    flag++;
    if(flag <= 1){
        cout << tree -> data << endl;
        return;

    }
    



}


int main(){
   int n;

    cin >> n;
    vector<int> pre(n);
    vector<int> in(n);

    for(int i = 0; i < n; i++){

        scanf("%d", &pre[i]);

    }

    for(int i = 0; i < n; i++){
        
        scanf("%d", &in[i]);

    }
    node * tree;
    tree = creat_tree(pre, in, 0, n - 1, 0, n -1);
    
    post_order(tree);

    return 0;
}
发布了38 篇原创文章 · 获赞 0 · 访问量 530

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104085540
今日推荐