PAT 1138 Postorder Traversal(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

思路:根据前序遍历和中序遍历建树,然后后序遍历,把结果存到数组。拿出第一个数即可。

程序:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstdlib>
using namespace std;
struct node
{
  int val;
  node* left;
  node* right;
};
vector<int> post;
node* createTree(vector<int> &pre,vector<int> &in,int pl,int pr,int il,int ir)
{
  if(pl > pr) return NULL;
  node* root = (node*)malloc(sizeof(node));
  root->val = pre[pl];
  root->left = NULL;
  root->right = NULL;
  int pos = il;
  while(in[pos] != pre[pl])
  {
    pos++;
  }
  root->left = createTree(pre,in,pl+1,pl+pos-il,il,pos-1);
  root->right = createTree(pre,in,pl+pos-il+1,pr,pos+1,ir);
  return root;
}
void postorder(node* root)
{
  if(root)
  {
    postorder(root->left);
    postorder(root->right);
    post.push_back(root->val);
  }
}
int main()
{
  int n;
  scanf("%d",&n);
  vector<int> pre,in;
  for(int i = 0; i < n ; i++)
  {
    int num;
    scanf("%d",&num);
    pre.push_back(num);
  }
  for(int i = 0; i < n; i++)
  {
    int num;
    scanf("%d",&num);
    in.push_back(num);
  }
  node* root = createTree(pre,in,0,n-1,0,n-1);
  postorder(root);
  printf("%d\n",post[0]);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Hickey_Chen/article/details/81223881
今日推荐