1138 Postorder Traversal(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

只要求输出后序的第一个那么分三种情况讨论

1 就一个根结点,直接输出

2 在右子树,根结点的位置都在第一个,遍历两个序列不一样的,中序的位置既是后序第一个,全部一样就输出最后一个

3 在左子树,直接输出先序左子树最后一个

#include<cstdio>
#include<fstream>
const int maxn=50010;
int a[maxn]={0};
int b[maxn]={0};

int main(){
	int n;
//	freopen("d://in.txt","r",stdin);
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		scanf("%d", &a[i]);
	}
	for(int i=0; i<n; i++){
		scanf("%d", &b[i]);
	}
	int x=a[0];
	
	for(int i=0; i<n; i++){
		if(x==b[i]){
			x=i;
			break;
		}
	}
	
	bool flag=false;
	if(n==1)printf("%d", a[0]);
	else if(x==0){
		for(int i=0; i<n; i++){
			if(a[i]!=b[i]){
				printf("%d", b[i]);
				flag=true;
				break;
			}
		}
		if(flag==false) printf("%d", b[n-1]);
	}
	else printf("%d", a[x]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Chuyuan_li/article/details/82224348
今日推荐