1138 Postorder Traversal (25 分)(树的先序中序转后序)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7

1 2 3 4 5 6 7

2 3 1 5 4 7 6

Sample Output:

3

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
vector<int> pre,in,post;
void postOrder(int root,int start,int end){
    if(start>end) return;
    int i=start;
    while(i<end&&in[i]!=pre[root]) i++;
    postOrder(root+1,start,i-1);
    postOrder(root+1+i-start,i+1,end);
    post.push_back(pre[root]);
}
int main() {
    int n;
    cin>>n;
    pre.resize(n);
    in.resize(n);
    for(int i=0;i<n;i++) cin>>pre[i];
    for(int i=0;i<n;i++) cin>>in[i];
    postOrder(0,0,n-1);
    cout<<post[0];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/87946886
今日推荐