HDU-4336 Min-Max容斥

Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7141 Accepted Submission(s): 3711
Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, …, pN, (p1 + p2 + … + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

Sample Input
1
0.1
2
0.1 0.4

Sample Output
10.000
10.500


我们知道Min-Max容斥,对期望也是满足的,所以我们可以利用Min去求Max。

Min是很好求的,对于任意一个子集,Min可以表示第一次拿到这个子集某一张的期望值。Max就是代表总集合最后一张票的时间。

扫描二维码关注公众号,回复: 8832324 查看本文章

AC代码:

#pragma GCC optimize("-Ofast","-funroll-all-loops")
#include<bits/stdc++.h>
//#define int long long
using namespace std;
const int N=25;
const double eps=1e-8;
double a[N],res;	int n;
void dfs(int x,int num,double sum){
	if(x==n+1){
		if(sum<eps)	return ;
		if(num&1)	res+=1.0/sum;
		else	res-=1.0/sum;
		return ;
	}
	dfs(x+1,num,sum);
	dfs(x+1,num+1,sum+a[x]);
}
signed main(){
	while(cin>>n){
		for(int i=1;i<=n;i++)	cin>>a[i];
		res=0;	dfs(1,0,0);
		printf("%.8lf\n",res);
	}
	return 0;
}
发布了467 篇原创文章 · 获赞 241 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43826249/article/details/104082549