HDU 4734 F(x) (数位DP)

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 382    Accepted Submission(s): 137


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 
Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 
Sample Input
3 0 100 1 10 5 100
 
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
 
题意
定义F(x) = An * 2n-1 + An-1 * 2n-2 + ... + A2 * 2 + A1 * 1。给A,B,求0到B的F(x)的小于等于F(A)的个数。
 
分析
数位DP。dp[i][j]为位数i的值小于等于j的个数。利用记忆化搜索
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
#include<bitset>
#include<map>
#include<deque>
#include<stack>
using namespace std;
typedef pair<int,int> pii;
#define X first
#define Y second
#define pb push_back
#define mp make_pair
typedef long long ll;
#define ms(a,b) memset(a,b,sizeof(a))
const int inf = 0x3f3f3f3f;
const int maxn = 2e5;
const int mod = 1e9+7;

#define lson l,m,2*rt
#define rson m+1,r,2*rt+1
int dp[15][maxn];
int bit[15];
int F(int A){
    int len=0;
    int res=0;
    while(A){
        res += (A%10)*(1<<len);
        len++;
        A/=10;
    }
    return res;
}

int dfs(int pos,int num,bool limit){
    if(pos==-1) return num>=0;
    if(num<0) return 0;
    if(!limit && dp[pos][num]!=-1) return dp[pos][num];
    int ed=limit?bit[pos]:9;
    int ans=0;
    for(int i=0;i<=ed;i++){
        ans+=dfs(pos-1,num-i*(1<<pos),limit && i==ed);
    }
    if(!limit) dp[pos][num]=ans;
    return ans;
}
int solve(int A,int B){
    int maxx = F(A);
    int pos=0;
    while(B){
        bit[pos++]=B%10;
        B/=10;
    }
    return dfs(pos-1,maxx,1);
}
int main(){
#ifdef LOCAL
    freopen("in.txt","r",stdin);
#endif // LOCAL
    int t,A,B;
    int cas=1;
    scanf("%d",&t);
    ms(dp,-1);
    while(t--){
        scanf("%d%d",&A,&B);
        printf("Case #%d: %d\n",cas++,solve(A,B));
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/fht-litost/p/8970161.html