F(x) (HDU-4734)(数位DP)

For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)

Output

For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.

Sample Input

3
0 100
1 10
5 100

Sample Output

Case #1: 1
Case #2: 2
Case #3: 13

题意:给你一个十进制的函数判别式,再给你a和b,问你从0到b的区间里,满足f(i)<=f(a)的数有几个。

思路:这道题的话是数位DP的做法,然后我们思考一下,当你想要枚举数位的时候,如果要是加权值的话,因为dp[pos][sum]的状态是基本的,而且f(a)最大的话是4600,如果要优化的话,就会变成dp[10][4600][4600],这显然是不合法的。

这个时候就要用减法了,dp[pos][sum],sum不是存当前枚举的数的前缀和(加权的),而是枚举到当前pos位,后面还需要凑sum的权值和的个数,也就是说初始的是时候sum是f(a),枚举一位就减去这一位在计算f(i)的权值,那么最后枚举完所有位 sum>=0时就是满足的,后面的位数凑足sum位就可以了。仔细想想这个状态是与f(a)无关的(新手似乎很难理解),一个状态只有在sum>=0时才满足,如果我们按常规的思想求f(i)的话,那么最后sum>=f(a)才是满足的条件。

AC代码:

#include <bits/stdc++.h>
const int maxx=10010;
const int inf=0x3f3f3f3f;
typedef long long ll;
using namespace std;
int all;
int a[20];
int dp[20][maxx];
int f(int x)
{
    if(x==0)
        return 0;
    int ans=f(x/10);
    return ans*2+(x%10);
}
int dfs(int pos,int sum,bool limit)
{
    if(pos==-1)
        return sum<=all;
    if(sum>all)
        return 0;
    if(!limit && dp[pos][all-sum]!=-1)
        return dp[pos][all-sum];
    int up=limit?a[pos]:9;
    int ans=0;
    for(int i=0; i<=up; i++)
    {
        ans+=dfs(pos-1,sum+i*(1<<pos),limit && i==a[pos]);
    }
    if(!limit)
        dp[pos][all-sum]=ans;
    return ans;
}
int solve(int x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,true);
}
int main()
{
    int n,m;
    int t;
    int k=1;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        scanf("%d%d",&n,&m);
        all=f(n);
        printf("Case #%d: %d\n",k++,solve(m));
    }
    return 0;
}
    
发布了204 篇原创文章 · 获赞 16 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43846139/article/details/103876036