#2020.01.14训练题解#二分入门(D题)

题源HDU-2199

HDU-2199-Can you solve this equation?

Description
Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
2
100
-4

Sample Output
1.6152
No solution!

题意

  • 输入T,代表有T组测试数据,每组测试数据输入Y,代表8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y中的Y
  • 对于每组测试数据,输出满足题意的x
  • x在0-100之间,保留四位小数输出即可
  • 如果没有满足题意的x,则输出No solution!

题解

  • 初始以0为left,100为right,然后对x的值进行二分尝试是否满足方程
  • 输入的y和计算的x长式,两者之差(大的减小的)若小于1e-6则看做方程成立
  • 因为用mid进行计算判断,也有先得出mid再if-else,最后**else break;**的过程
  • 所以输出mid即可,注意保留四位小数

涉及知识点

  • 二分 算法(此题属于实数二分)
  • 对于二分的算法-详见链接博客介绍二分

AC代码

#include<stdio.h>
#include<cstdio>
#include<algorithm>
using namespace std;
int n;
int main()
{
	int T;
	double x,y;
	scanf("%d",&T);
	for(int i=0;i<T;i++)
	{
		int sum=0,flag=0;
		scanf("%lf",&y);
		if(y>807020306||y<6) printf("No solution!\n");
		else
		{
			double left=0,mid,right=100;
			while(right-left>1e-6)
			{
				mid=(left+right)/2;
				if(8*mid*mid*mid*mid+7*mid*mid*mid+2*mid*mid+3*mid+6-y>1e-6) right=mid;
				else if(y-(8*mid*mid*mid*mid+7*mid*mid*mid+2*mid*mid+3*mid+6)>1e-6) left=mid;
				else break;
			}
			printf("%.4f\n",mid);
		}
	}
	return 0;
}
发布了20 篇原创文章 · 获赞 0 · 访问量 402

猜你喜欢

转载自blog.csdn.net/qq_46184427/article/details/104073761