C 数据结构实验之链表三:链表的逆置 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


Input

输入多个整数,以-1作为结束标志。


Output

输出逆置后的单链表数据。


Sample Input

12 56 4 6 55 15 33 62 -1


Sample Output

62 33 15 55 6 4 56 12


Hint

不得使用数组。


Source


链表逆序可以直接定义一个逆序链表;

#include <stdio.h>
#include <stdlib.h>
  struct node
  {
      int a;
      struct node *next;
  };
 void  show(struct node *head)
   {
       struct node *p;
       p = head -> next;
       while(p)
       {
           if(p->next==NULL)
           printf("%d",p->a);
           else printf("%d ",p->a);
           p = p-> next;

       }
   }
     int main()
     {
         int a1;
         struct node *head,*p;
         head = (struct node*)malloc(sizeof(struct node));
         head -> next = NULL;
         while(scanf("%d",&a1))
         {
             if(a1==-1) break;
             p = (struct node*)malloc(sizeof(struct node));
             p -> next = head -> next;
             head -> next = p;
             p -> a = a1;

         }
         show(head);
         return 0;
     }


发布了162 篇原创文章 · 获赞 119 · 访问量 3214

猜你喜欢

转载自blog.csdn.net/zhangzhaolin12/article/details/104027937