SDUT2118数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Sample Input

12 56 4 6 55 15 33 62 -1

Sample Output

62 33 15 55 6 4 56 12

Hint

不得使用数组。

Source


#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *str()
{
    struct node *p,*tail,*head;
    head = (struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    while(p!=NULL)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
        if(p->data==-1)break;
    }
    return head;
};
void pr(struct node *head)
{
    struct node *p,*q;
    p=head->next;
    q=p->next;
    head->next=NULL;
    while(p->data!=-1)
    {
        p->next=head->next;
        head->next=p;
        p=q;
        if(p->data!=-1)
            q=q->next;
    }
}
void print(struct node *head)
{
    int n=0;
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(n==0)
        {
            printf("%d",p->data);
            n=1;
        }
        else
            printf(" %d",p->data);
        p=p->next;
    }
}
int main()
{
    struct node *h;
    h=str();
    pr(h);
    print(h);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81530002