2019_GDUT_新生专题I选集 J POJ-1905

题目:

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion. When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.
Your task is to compute the distance by which the center of the rod is
displaced.
在这里插入图片描述
Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000

做法:二分。二分的对象是当前答案算出来的圆弧长度,长于当前温度下弯曲的长度则缩小答案,短于弯曲的长度则加大答案。

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

int main()
{
	double L,n,c,LL,ans,l,r,mid,R;
	cin>>L>>n>>c;
	while (L!=-1 && n!=-1 && c!=-1)
	{
		LL=(1+n*c)*L;
		r=L/2;
		l=0;
		while (r-l>1e-8)
		{
			mid=l+(r-l)/2;
			R=L*L/8/mid+mid/2;
			ans=2*R*asin(L/2/R);
			if(ans<LL)
			l=mid;
			else r=mid;
		}
		printf("%.3f\n",l);
		cin>>L>>n>>c;
	}
	return 0;
}
发布了14 篇原创文章 · 获赞 0 · 访问量 298

猜你喜欢

转载自blog.csdn.net/qq_39581539/article/details/103964855
今日推荐