2019_GDUT_新生专题I选集 K HUD-3714

题目:

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties. In order to test the algorithm’s efficiency, she collects many datasets. What’s more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
在这里插入图片描述
It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?
Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000

做法:每次都是取最大的二次函数的值,且a>0,故所有二次函数都是开口向上的,所以取最大值后的函数图像也是一个类似二次函数先下降再上升的图像。套用三分的模板,函数值则是用max暴力算出。本题要求的精度较高,且需要考虑函数值可能是负数。

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
struct function
{
	int a,b,c;
}a[11000];
int n;
double F(double x)
{
	double m=-1e10;
	for (int i=1;i<=n;i++)
		m=max(m,a[i].a*x*x+a[i].b*x+a[i].c);
	return m;
}
int main()
{
	int T;
	double l,r,mid1,mid2;
	cin>>T;
	while (T--)
	{
		memset(a,0,sizeof(a));
		cin>>n;
		for (int i=1;i<=n;i++)
			scanf("%d%d%d",&a[i].a,&a[i].b,&a[i].c);
		l=0;
		r=1000;
		while (fabs(r-l)>1e-10)
		{
			mid1=(l+r)/2;
			mid2=(mid1+r)/2;
			if (F(mid1)<F(mid2))
				r=mid2;
			else
				l=mid1;
		}
		printf("%.4lf\n",F(l));
	}
	return 0;
}
发布了14 篇原创文章 · 获赞 0 · 访问量 296

猜你喜欢

转载自blog.csdn.net/qq_39581539/article/details/103964929