1059 Prime Factors (25 分)(唯一分解定理,特判1=1,呵呵)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

特判1=1

#include<bits/stdc++.h>
#pragma GCC optimize(3)
#define max(a,b) a>b?a:b
using namespace std;
typedef long long ll;
const int N=5e5+5;
int prime[N],cnt=0;
bool p[N];
void is_p(){
	p[0]=p[1]=true;
	for(int i=2;i<N;i++){
		if(!p[i]) prime[cnt++]=i;
		for(int j=0;j<cnt&&(ll)i*prime[j]<N;j++){
			p[i*prime[j]]=true;
			if(i%prime[j]==0) break;
		}
	}
}
struct node{
	int p,k;
}a[N];
int main(){
    is_p();
    int n;
    scanf("%d",&n);
    int x=n;
    printf("%d=",n);
    if(n==1){
    	printf("%d\n",n);
	return 0; 
    } 
    int t=0;
    for(int i=0;i<cnt&&x!=1;i++){
    	if(x%prime[i]==0){
    	   int res=0;
    	   while(x%prime[i]==0){
    		res++;
    		x/=prime[i];
	   }
	   a[++t]={prime[i],res};
	}
    }
    if(x!=1) a[++t]={x,1};
    for(int i=1;i<=t;i++){
	printf("%d",a[i].p);
	if(a[i].k>1) printf("^%d",a[i].k);
	printf("%c","*\n"[i==t]);
    }
    return 0;
}





发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103267978