Cow Hurdles POJ - 3615(floyd 单端路最大值最小)

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows’ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1…N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1…M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

Input

  • Line 1: Three space-separated integers: N, M, and T
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi
  • Lines M+2…M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

  • Lines 1…T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input
5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1
Sample Output
4
8
-1

题意: 求A到B单端路最大值的最小值
思路:
对dp方程做修改就好了。
dp(i,j) = min{ max(dp(i,k),dp(k,j) }
注意枚举的时候,k要在最外层,作为阶段,k作为中间点的情况全部算完,才能往下走。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const int maxn = 305;
const int INF = 0x3f3f3f3f;
int d[maxn][maxn];

int main()
{
    int n,m,t;
    while(~scanf("%d%d%d",&n,&m,&t))
    {
        memset(d,INF,sizeof(d));
        for(int i = 1;i <= n;i++)d[i][i] = 0;
        for(int i = 1;i <= m;i++)
        {
            int x,y,z;scanf("%d%d%d",&x,&y,&z);
            d[x][y] = z;
        }
        
        for(int k = 1;k <= n;k++)
        {
            for(int i = 1;i <= n;i++)
            {
                for(int j = 1;j <= n;j++)
                {
                    if(d[i][k] != INF  && d[k][j] != INF)
                    {
                        d[i][j] = min(d[i][j],max(d[i][k],d[k][j]));
                    }
                }
            }
        }

        while(t--)
        {
            int x,y;scanf("%d%d",&x,&y);
            if(d[x][y] == INF)printf("-1\n");
            else printf("%d\n",d[x][y]);
        }
    }
    return 0;
}



发布了594 篇原创文章 · 获赞 16 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/103978687