Easy Task

描述

Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))’ to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules:
(1) ©’=0 where C is a constant.
(2) (Cxn)’=C*n*x(n-1) where n>=1 and C is a constant.
(3) (f1(x)+f2(x))’=(f1(x))’+(f2(x))’.
It is easy to prove that the derivation a polynomial is also a polynomial.

Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?

输入

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1000) which is the number of test cases. And it will be followed by T consecutive test cases.

There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integer N (0 <= N <= 1000). The second line contains N + 1 non-negative integers, CN, CN-1, …, C1, C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x). Ci is the coefficient of the term with degree i in f(x). (CN!=0)

输出

For each test case calculate the result polynomial g(x) also in a single line.
(1) If g(x) = 0 just output integer 0.otherwise
(2) suppose g(x)= Cmxm+Cm-1x(m-1)+…+C0 (Cm!=0),then output the integers Cm,Cm-1,…C0.
(3) There is a single space between two integers but no spaces after the last integer.

样例输入
3
0
10
2
3 2 1
3
10 0 1 2
样例输出
0
6 2
30 0 1
分析:模拟
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int T;
cin>>T;
while(T–)
{
int n,a[1010],b[1010];
cin>>n;
for(int i=0;i<=n;i++)
{
cin>>a[i];
b[i]=a[i]*(n-i);
}
if (!n)
{
cout<<“0”<<endl;
continue;
}
for (int i=0;i<n;i++)
{
if (i) cout<<’ ';
cout<<b[i];
}
cout<<endl;
}
return 0;
}

发布了40 篇原创文章 · 获赞 0 · 访问量 680

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/103434345
今日推荐