Easy Math

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/yuewenyao/article/details/88862922

题目

Easy Math

Given nn integers a1,a2,…,ana1,a2,…,an, check if the sum of their square root a1−−√+a2−−√+⋯+an−−√a1+a2+⋯+an is a integer.

Input

The input consists of multiple tests. For each test:

The first line contains 11 integer nn (1≤n≤1051≤n≤105). The second line contains nn integers a1,a2,…,ana1,a2,…,an (0≤ai≤1090≤ai≤109).

Output

For each test, write "Yes" if the sum is a integer, or "No" otherwise.

Sample Input

    2
    1 4
    2
    2 3

Sample Output

    Yes
    No

题意:就是给你n个整数,求这n个数的平方根是否为一个整数。算是一个水题吧。

AC代码:

#include<stdio.h>
#include<math.h>
int a[150005];
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        int flag = 1;
        for(int i = 0; i < n ; i ++)
        {
            scanf("%d",&a[i]);
            int p=(int)sqrt( 1.0 * a[i] + 0.5) + 1;
            while(flag)
            {
                if((int) p * p == a[i])
                {
                    break;
                }
                if((int) p * p < a[i])
                {
                     flag = 0;
                }
                p--;
            }

        }
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/yuewenyao/article/details/88862922
今日推荐