【ZOJ - 2969】Easy Task (模拟,数学)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/88168356

题干:

Calculating the derivation of a polynomial is an easy task. Given a function f(x) , we use (f(x))' to denote its derivation. We use x^n to denote xn. To calculate the derivation of a polynomial, you should know 3 rules: 
(1) (C)'=0 where C is a constant. 
(2) (Cx^n)'=C*n*x^(n-1) where n>=1 and C is a constant. 
(3) (f1(x)+f2(x))'=(f1(x))'+(f2(x))'. 

It is easy to prove that the derivation a polynomial is also a polynomial.

Here comes the problem, given a polynomial f(x) with non-negative coefficients, can you write a program to calculate the derivation of it?

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1000) which is the number of test cases. And it will be followed by T consecutive test cases.

There are exactly 2 lines in each test case. The first line of each test case is a single line containing an integer N (0 <= N <= 100). The second line contains N + 1 non-negative integers, CNCN-1, ..., C1C0, ( 0 <= Ci <= 1000), which are the coefficients of f(x). Ci is the coefficient of the term with degree i in f(x). (CN!=0)

Output

For each test case calculate the result polynomial g(x) also in a single line. 
(1) If g(x) = 0 just output integer 0.otherwise 
(2) suppose g(x)= Cmx^m+Cm-1x^(m-1)+...+C0 (Cm!=0),then output the integers Cm,Cm-1,...C0.
(3) There is a single space between two integers but no spaces after the last integer. 

Sample Input

3
0
10
2
3 2 1
3
10 0 1 2

Sample Output

0
6 2
30 0 1

题目大意:

   给出一个m阶函数的各项的系数,让你求一阶导数。如果导数值为0,那就直接输出一个0就可以了。注意如果中间有0,那也要输出。

解题报告:

   水题,直接模拟就行了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 2e5 + 5;
int a[MAX];
string s;
int main() {
	int t;
	cin>>t;
	while(t--) {
		int x,flag = -1,ok=0;
		scanf("%d",&x);
		for(int i = x; i>=0; i--) {
			scanf("%d",a+i);
			if(a[i] != 0 && ok==0) flag = i,ok=1;
		}
		if(x == 0 || ok == 0) {
			printf("0\n");continue;
		}
		for(int i = flag; i>=1; i--) {
			printf("%lld%c",1ll*i*a[i],i == 1 ? '\n' : ' ');
		}
	}

	return 0 ;
}
/*
1
3
0 2 3 4
*/

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/88168356
ZOJ