hdu3635 并查集

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
 
题意:第i个城市有i号龙珠,T x y代表移动 x->y       
    Q a询问   
  输出 a所在的城市,a所在城市的龙珠数量,a的移动次数
 
 
每次合并的时候 都当做是第一次移动   即 cnt[x]=1;
cnt记录移动次数,其值为 父亲节点的移动次数+ 自己的移动次数;
递归的时候每次都要加上其父亲节点的移动次数
 
最后输出的时候需要再一次find 压缩路径   跟cnt数组才是正确答案;
#include <bits/stdc++.h>
using namespace std;
const int  maxn=1e4+5;
int pre[maxn]; //父节点 
//int height[maxn]; //树的高度 
int sum[maxn]; //球的数量 
int cnt[maxn]; //次数; 
void init(){
	for(int i=1;i<=maxn;i++){
		pre[i]=i;
		//height[i]=0; //树的高度
		sum[i]=1;
		cnt[i]=0; 
	}
}
int find(int x)   //合并路径 找根  带权 
{  
    if(pre[x]==x)  
        return pre[x];  
    else  
    {  
    	int temp=pre[x];
        int root = find(pre[x]);  
        cnt[x] += cnt[temp];
        return pre[x] = root;  
    }  
}  
//int find_set(int x){
//	if(pre[x]==x) return x;
//	else {
//		while(pre[x]!=x) {   //非递归实现 
//			x=pre[x];
//		}
//		return pre[x];
//	}
//}

int union_set2(int x, int y){
	x=find(x);
	y=find(y);
	if(x!=y){
		pre[x]=y;
		sum[y]+=sum[x];
		cnt[x]=1;
		sum[x]=0;
	}
}
int main(){
	int t;
	scanf("%d",&t);
	for(int l=1;l<=t;l++){
		int n,q;
		scanf("%d%d",&n,&q);
		init();  
		printf("Case %d:\n",l);      
		for(int i=0;i<q;i++){
			char c[5];
			scanf("%s",&c);
			if(c[0]=='T') {
				int x,y;
				scanf("%d%d",&x,&y);
				union_set2(x,y);
			}else if(c[0]=='Q'){
				int a;
				scanf("%d",&a);
				int root=find(a); 
				
				printf("%d %d %d\n",pre[a], sum[root],cnt[a]);
			}
		} 
	}
	return 0;
} 

  

猜你喜欢

转载自www.cnblogs.com/lyj1/p/11892482.html
今日推荐