大理石在哪儿 UVa10474

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_43269048/article/details/99695419

先粘一下题目

Raju and Meena love to play with Marbles. They have got a lot of
marbles with numbers written on them. At the beginning, Raju would
place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble
with a certain number. She would count 1…2…3. Raju gets one point
for correct answer, and Meena gets the point if Raju fails. After some
fixed number of trials the game ends and the player with maximum
points wins. Today it’s your chance to play as Raju. Being the smart
kid, you’d be taking the favor of a computer. But don’t underestimate
Meena, she had written a program to keep track how much time you’re
taking to give all the answers. So now you have to write a program,
which will help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins
with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next
N lines would contain the numbers written on the N marbles. These marble numbers will not come
in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers
are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.
Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether
or not the query number is written upon any of the marbles. The two different formats are described
below:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered
1, 2, . . . , N.
• ‘x not found’, if the marble with number x is not present.
Look at the output for sample input for details.
Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

解题思路

直接看输入格式,第一行输入int的n,q ,其中n表示有几块大理石,q表示有几个问题,接下来n行分表表示n块大理石上的数字,对这n个数直接排序即可,接下来的一行表示要找的大理石上的数字。输出格式:对应每个问题都单独占一行,在排序后的数组中找到该数字的位置并输出,如果没有找到该数字,即直接输出找不到。
只需两步,先排序(直接使用algorithm头文件中的sort排序),后查找(对于排序后的数组,要找到某一数字,只需要找到第一个大于或者等于该数字的位置,看该位置的数字是否是所查找的数字即可,使用lower_bound函数完成该操作即可)

完整代码:

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn=10000;
int main()
{
   int n,q,x,a[maxn],kase=0;
   while(scanf("%d%d",&n,&q)==2 &&n){
    printf("CASE# %d:\n",++kase);
    for(int i=0;i<n;i++)scanf("%d",&a[i]);
    sort(a,a+n);//排序
    while(q--){
        scanf("%d",&x);
        int p=lower_bound(a,a+n,x)-a; //在已经排序的数组a中寻找x
        if(a[p]==x)printf("%d found at %d\n",x,p+1);
        else printf("%d not found\n",x);
    }
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43269048/article/details/99695419