排序和查找-UVa10474

Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.


现有N个大理石,每个大理石上写了一个非负整数。首先把各个数从下到大排序,然后回答Q个问题。每个问题是否有一个大理石写着这个数,如果是,回答在哪个大理石上写着x。白须后的大理石从左到右编号为1-N。

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.

  Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

  For each of the queries, print one line of output. The format of this line will depend upon whetheror not the query number is written upon any of the marbles. The two different formats are describedbelow:

  • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered1, 2, . . . , N.

  • ‘x not found’, if the marble with number x is not present.

  Look at the output for sample input for details.

Sample Input

4 1

5

5 2

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3


问题链接UVA10474 Where is the Marble?

题意简述

  输入n个整数,代表大理石编号;再输入q个数(编号),问是否有这个编号的大理石,位置在哪里?

问题分析:(略)

程序说明

  这个问题用C++语言编写程序,主要是为了练习使用STL的功能。

  程序中,使用了算法库(algorithm)中的两个函数;使用sort()函数用于对数据排序,该函数的参数比C语言的同类函数简单,程序更加易于书写;使用函数lower_bound()查找元素,简单方便。


AC的C++语言程序如下:

#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define MAXN 11000
int main()
{
    int n,q,caseno=0,val,i;
    int marble[MAXN];
    while(scanf("%d %d",&n,&q)!=EOF){
        if(n==0&&q==0)
            break;
        
        for(i=0;i<n;i++){
            scanf("%d",&marble[i]);
        }                 
        
        sort(marble,marble+n);
        
        printf("CASE# %d:\n",++caseno);
        while(q--){
            scanf("%d",&val);
            int no=lower_bound(marble,marble+n,val)-marble;
            if(marble[no]==val)
                printf("%d found at %d\n",val,no+1);
            else
                printf("%d not found\n",val);
        }
    }
    cin>>i;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/jake1223/article/details/79460848
今日推荐