poj 2342 树形DP入门题

Anniversary party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions:13782   Accepted: 7823

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

#include<stdio.h>//网上大佬的代码 
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=6004;
int dp[maxn][2];//dp[i][0]代表i这个点不取,dp[i][1]代表这个点取。 
bool vis[maxn];//标记每个点,防止重复. 
int father[maxn];//记录每个子节点的父亲节点 
int n,root;

void void_tree(int r)//和dfs的思路一样,边搜索变更新;      
{
    vis[r]=1;
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&father[i]==r)
        {
             void_tree(i);
            dp[r][1]+=dp[i][0];//如果领导去,则员工不能去; 
            dp[r][0]+=max(dp[i][0],dp[i][1]);//如果领导不去,员工可去可不去; 
        }
    }
}
 
int main()
{
    memset(dp,0,sizeof(dp));
    memset(vis,0,sizeof(vis));
    memset(father,0,sizeof(father));
    root=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&dp[i][1]);//输入如果去的值; 
    }
    int s,t;
    while(scanf("%d %d",&s,&t)&&(s||t))
    {
        father[s]=t;//s的父节点是t; 
    }
   /* for(int i=1;i<=n;i++)
        printf("%d %d\n",i,father[i]);*/
    void_tree(root);
    //printf("%d\n",root);
    int sum=max(dp[root][1],dp[root][0]);
    printf("%d\n",sum);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/qqshiacm/p/11688077.html
今日推荐