POJ2342 Anniversary party 树形dp

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

解题思路:

题意为有n个人要开一个PARTY,编号1到n,每个人都有一个欢乐值,并且每个人都有一个直接上司,为了让气氛更好,要求在这n个人中选一些人去参加PARTY,并且选出的这些人中任意两个人之间都没有直接上司或直接下属关系,求选出人的最大欢乐值。

这n个人通过直接上司或直接下属关系构成了一棵树,如果把父节点看做直接上司,那么子节点为下属,而且上司和下属不能同时选择。

定义dp[i][0] 为第i个人不选择所获得的最大欢乐值,dp[i][1] 为第i个人被选择所获得的最大欢乐值

假设 j 是第i个人的下属, 那么有转移方程  :

dp[i][0]+=max( dp[j][0],dp[j][1]);  注意是+=,因为一个父节点有多个子节点

dp[i][1]+=dp[j][0];

用DFS遍历这棵树,每个顶点被访问,且只被访问一次。

思路1:无向图,忽略原题中的上下级(其实谁是上级谁是下级无所谓,主要他俩不同时出现就行)

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> v[6005];
int dp[6005][2],n;
bool vis[6005];
void dfs(int x){
	vis[x]=true;
	for(int i=0;i<v[x].size();i++){
		int t=v[x][i];
		if(!vis[t]){
			dfs(t);
			dp[x][1]+=dp[t][0];// 上司和下司不能同时去 
			dp[x][0]+=max(dp[t][0],dp[t][1]); 
		}
	}
}
int main(){
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;i++)
		v[i].clear();
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++){
			scanf("%d",&dp[i][1]);
			dp[i][0]=0;
		}
		int l,k;
		while(scanf("%d%d",&l,&k)){
			if(l==0&&k==0) break;
			v[k].push_back(l);
			v[l].push_back(k);
		} 
		dfs(1);
		printf("%d\n",max(dp[1][1],dp[1][0]));
	}
	return 0;
} 

 思路2:有向图,按照题中的上下级,找出根,然后dfs

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> v[6005];
int dp[6005][2],n;
bool vis[6005],isroot[6005];
void dfs(int x){
	vis[x]=true;
	for(int i=0;i<v[x].size();i++){
		int t=v[x][i];
		if(!vis[t]){
			dfs(t);
			dp[x][1]+=dp[t][0];// 上司和下司不能同时去 
			dp[x][0]+=max(dp[t][0],dp[t][1]); 
		}
	}
}
int main(){
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;i++)
		v[i].clear();
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++){
			scanf("%d",&dp[i][1]);
			dp[i][0]=0;
			isroot[i]=true;
		}
		int l,k;
		while(scanf("%d%d",&l,&k)){
			if(l==0&&k==0) break;
			v[k].push_back(l);
			isroot[l]=false;
		} 
		int root=0;
		for(int i=1;i<=n;i++){
			if(isroot[i]){
				root=i;
				break;
			}
		}
		dfs(root);
		printf("%d\n",max(dp[root][1],dp[root][0]));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/86530440