【POJ - 2342】Anniversary party(树形dp)

版权声明:如果有什么问题,欢迎大家指出,希望能和大家一起讨论、共同进步。 https://blog.csdn.net/QQ_774682/article/details/83895687

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:

你需要选一部分人去派对,每个人都有一个权值,但是员工和他的直接主管不能同时选,问最大的权值和是多少。

思路:

第一次做的树形dp,没啥思路,看了别人的代码后,感觉有了点理解。这道题目中先算员工再算他的主管,先确定叶节点去不去的最大权值,再求他的直接上级时,就根据其子节点的去不去的权值推出,就这样一直往上推,因此这里用了dfs,而且这里求根节点的方法也可以记一下(自己没想到)。

poj这道题目是单组输入的,hdu也有一道同样的题是多组输入的。

ac代码:

/*
这一道题目是由子节点向根节点来推的
*/
#include<stdio.h>
#include<string.h>
#include<queue>
#include<set>
#include<iostream>
#include<map>
#include<stack>
#include<cmath>
#include<algorithm>
#define ll long long
#define mod 1000000007
#define eps 1e-8
using namespace std;
struct node{
	int v;
	int next;
}side[12000];
int head[7000];
int cnt=0;
void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
}
void add(int x,int y)
{
	side[cnt].v=y;
	side[cnt].next=head[x];
	head[x]=cnt++;
}
//dp[i][1]表示选第i个人事达到的最大值,dp[i][0]表示不选第i个人达到的最大值 
int dp[7000][2];// 每个人有两个状态 
void dfs(int cur)//cur指的是父节点 
{
	for(int i=head[cur];i!=-1;i=side[i].next)
	{
		int ty=side[i].v;//子节点 
		dfs(ty); 
		dp[cur][1]+=dp[ty][0];
		dp[cur][0]+=max(dp[ty][1],dp[ty][0]);
	}
	return ;
}
int main()
{
	init();
	int n;
	scanf("%d",&n);
	memset(dp,0,sizeof(dp));
	for(int i=1;i<=n;i++)
	scanf("%d",&dp[i][1]);
	int u,v;
	int root=(n)*(n+1)/2;//根节点,一开始是所有人的编号之和 
	while(~scanf("%d%d",&u,&v),u+v)
	{
		add(v,u);//加边 
		root-=u;
		//因为每个人只能有一个直属上司,即只有一个父节点,所以不是最高领导的人都会在u的位置出现一次,且只有一次,
		//之前已经把所有人的编号都加和,再减去不符合条件的人的编号,就是要求的根节点的编号 。 
	}
	dfs(root);//从根节点往下搜,搜到叶节点,在向上推 
	cout<<max(dp[root][1],dp[root][0])<<endl;//最后的信息都会汇集到根节点,因此只用看看根节点的两个信息是否符合。 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/QQ_774682/article/details/83895687