Anniversary party POJ - 2342 (树型dp)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:公司有n个人,每个人都有一个愉悦值,现在,公司举行聚会,但是,如果在聚会期间,碰上自己的直属上司的话,这个人就会不开心,给出n-1条关系,s,f,表示f是s的直属上司,问,最大可能的愉悦值是多少。

思路:首先,我们考虑,如果一个人的上司去参见聚会,那么,这个人就不能去了,如果上司不去,那么这个人可去,可不去。我们需要求出最大可能的情况。我们可以考虑用树型dp来做,dp[i][1],表示第i个人去时的愉悦值,dp[i][0]表示第i个人不去时的愉悦值,如果我们按照上下级关系进行dfs的话,那么就可以有:令u是上级,i是u的下属,vector G记录上下级关系

for i...G[u].size

    dp[u][1]+=dp[i][0],  dp[u][0]+=max(dp[i][1],dp[i][0])

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
const int Max=6005;
vector<int>G[Max];
bool vis[Max];
int dp[Max][2];
int n;
void dfs(int u)
{
    vis[u]=1;
    for(int i=0;i<G[u].size();i++){
        int v=G[u][i];
        if(!vis[v]){
            dfs(v);
            dp[u][1]+=dp[v][0];
            dp[u][0]+=max(dp[v][0],dp[v][1]);
        }
    }
}
int main()
{
    scanf("%d",&n);
    for(int i=0;i<=n;i++) G[i].clear();
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        scanf("%d",&dp[i][1]);
        dp[i][0]=0;
    }
    int f,s;
    while(~scanf("%d%d",&s,&f)){
        if(s==0&&f==0) break;
        G[f].push_back(s);//如果上司在,那么下属不能在,反过来说,如果下属在,上司同样也不能出现
        G[s].push_back(f);//所以建立双向边
    }
    dfs(1);
    cout<<max(dp[1][0],dp[1][1])<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41874469/article/details/81196645