POJ2342:Anniversary party(树形DP)

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

 AC代码:

#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 6060;
vector<int>v[maxn];       //v[i] 存放 其下属
int dp[maxn][2];          //dp[i][0]表示 i 没有参加聚会,dp[i][1]表示参加
int vis[maxn];

void init(){
    for(int i = 0;i < maxn;i ++) v[i].clear();
    memset(dp,0,sizeof(dp));
    memset(vis,0,sizeof(vis));
}

void dp_(int root){
    vis[root] = 1;
    for(int i = 0;i < v[root].size();i ++){
        int son = v[root][i];
        if(!vis[son]){
            dp_(son);
            dp[root][1] += dp[son][0];                 //编号root 去, 则其下属不能去 
            dp[root][0] += max(dp[son][0],dp[son][1]); //编号root 不去,则加上 下属去或不去中大的
        }
    }
}

int main()
{
    int n,w;
    while(~scanf("%d %d",&n,&w)){
        if(!n && !w) break;
        init();
        dp[1][1] = w;
        int l,k;
        for(int i = 2;i <= n;i ++)
            scanf("%d",&dp[i][1]);
        for(int i = 1;i < n;i ++){
            scanf("%d%d",&l,&k);
            v[k].push_back(l);
            v[l].push_back(k);
        }
        dp_(1);
        printf("%d\n",max(dp[1][1],dp[1][0]));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_o_ac/article/details/81124066