HDU 4857 逃生 (拓扑排序)

Problem Description
糟糕的事情发生啦,现在大家都忙着逃命。但是逃命的通道很窄,大家只能排成一行。

现在有n个人,从1标号到n。同时有一些奇怪的约束条件,每个都形如:a必须在b之前。
同时,社会是不平等的,这些人有的穷有的富。1号最富,2号第二富,以此类推。有钱人就贿赂负责人,所以他们有一些好处。

负责人现在可以安排大家排队的顺序,由于收了好处,所以他要让1号尽量靠前,如果此时还有多种情况,就再让2号尽量靠前,如果还有多种情况,就让3号尽量靠前,以此类推。

那么你就要安排大家的顺序。我们保证一定有解。
 
Input
第一行一个整数T(1 <= T <= 5),表示测试数据的个数。
然后对于每个测试数据,第一行有两个整数n(1 <= n <= 30000)和m(1 <= m <= 100000),分别表示人数和约束的个数。

然后m行,每行两个整数a和b,表示有一个约束a号必须在b号之前。a和b必然不同。
 
Output
对每个测试数据,输出一行排队的顺序,用空格隔开。
 
Sample Input
1 5 10 3 5 1 4 2 5 1 2 3 4 1 4 2 3 1 5 3 5 1 2
 
Sample Output
1 2 3 4 5
 
Author
CLJ
 
Source

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <map>
#include <vector>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
using namespace std;
#define mem(s,t) memset(s,t,sizeof(s))
#define pq priority_queue
#define pb push_back
#define fi first
#define se second
#define ac return 0;
#define TLE std::ios::sync_with_stdio(false);   cin.tie(NULL);   cout.tie(NULL);   cout.precision(10);
string str;
set <int> id;
int cnt[30000+10];
vector <int> edge[30000+10];
//pq<int , vector<int> ,greater<int> >q;
pq<int>q;
vector <int> ans;
int n,m,k,l,r,t;
void solve()
{
    while(!q.empty())
        q.pop();
    ans.clear();
    for(int i=1; i<=n; i++)
        if(!cnt[i])
            q.push(i);
    while(!q.empty())
    {
        int now = q.top();
        q.pop();
        ans.pb(now);
        for(int i=0; i<edge[now].size(); i++)
        {
            int x=edge[now][i];
            cnt[x]--;
            if(!cnt[x])
                q.push(x);
        }
    }
    for( int i=ans.size()-1; i>0; i-- )
        cout<<ans[i]<<" ";
    cout<<ans[0]<<endl;
}
int main()
{
    TLE;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=1; i<=n; i++)
        {
            edge[i].clear();
            cnt[i]=0;
        }
        while(m--)
        {
            cin>>l>>r;
            edge[r].pb(l);
            cnt[l]++;
        }
        solve();
    }
    ac;
}

猜你喜欢

转载自www.cnblogs.com/Shallow-dream/p/11681102.html
今日推荐