(高考加油!!!@大肥)1045 Favorite Color Stripe (30 分)

 Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

伊娃试图用特定的颜色制作自己的颜色条纹。她希望通过切掉那些不需要的碎片并将剩下的部分缝合在一起形成她最喜欢的彩色条纹,以她最喜欢的顺序保留她最喜欢的颜色。

据说普通人眼可以区分少于200种不同颜色,因此伊娃最喜欢的颜色是有限的。然而原始条纹可能很长,而Eva希望拥有最大长度的剩余最喜欢的条纹。所以她需要你的帮助才能找到最好的结果。

请注意,解决方案可能不是唯一的,但您只需要告诉她最大长度。例如,给定条纹颜色{2 2 4 1 5 5 6 3 1 1 5 6}。如果Eva最喜欢的颜色以她最喜欢的顺序给出{2 3 1 5 6},那么她有4种可能的最佳解决方案{2 2 1 1 1 5 6},{2 2 1 5 5 5 6},{2 2 1 5 5 6 6}和{2 2 3 1 1 5 6}。

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7
#include<iostream>
using namespace std;
int book[20],a[10001],dp[10001];
int main()
{
    int n,m,x,l,num=0,maxn=0;
    cin>>n>>m;
    for(int i=1;i<=m;i++)
    {
        cin>>x;
        book[x]=i;
    }///给要找的数一个特定的值
///book[2]=0,book[3]=1,book[1]=2,book[5]=3,book[6]=4;
    cin>>l;
    for(int i=0;i<l;i++)
    {
        cin>>x;
        if(book[x]>=1)
            a[num++]=book[x];
    ///把要找的数传进动规数组
    }
///    for(int i=0;i<num;i++)
///        cout<<a[i]<<" ";
///   1 1 3 4 4 5 2 3 3 4 5
    for(int i=0;i<num;i++)
    {///动规边界,长度为1
        dp[i]=1;
        for(int j=0;j<i;j++)
        if(a[i]>=a[j])
            dp[i]=max(dp[i],dp[j]+1);
        maxn=max(dp[i],maxn);
    }
    cout<<maxn;
}

猜你喜欢

转载自blog.csdn.net/qq_43813697/article/details/90905139
今日推荐