poj2342 Anniversary party

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

题意:
某公司要举办一次晚会,但是为了使得晚会的气氛更加活跃,每个参加晚会的人都不希望在晚会中见到他的直接上司,现在已知每个人的活跃指数和上司关系(当然不可能存在环),求邀请哪些人(多少人)来能使得晚会的总活跃指数最大。

用dp[i][[0]和dp[i][1]表示第i个人不来和来

当i来的时候,i的直接下属不来,
dp[i][1] +=dp[j][0],j为i的直接下属
当i不来的时候,i的直接下属可来可不来
dp[i][0] +=max(dp[j][1],dp[j][0]);//j为i的下属

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxx = 6010;
int dp[maxx][2];
int par[maxx];
bool vis[maxx];
int n;

void solve(int root)
{
    vis[root] = 1;
    int i;
    for(i=1; i<=n; i++)
    {
        if(par[i]==root&&!vis[i])
        {
            solve(i);
            dp[root][1] +=dp[i][0];
            dp[root][0] +=max(dp[i][1],dp[i][0]);
        }
    }
}


int main()
{
    while(cin>>n)
    {
        memset(dp,0,sizeof(dp));
        memset(par,0,sizeof(par));
        memset(vis,false,sizeof(vis));
        int i;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);
        }
        int u,v;
        int root;
        while(scanf("%d %d",&u,&v)&&(u+v))
        {
            par[u] = v;
            vis[u] = 1;

        }
        for(i=1; i<=n; i++)
        {
            if(!vis[i])
                break;
        }
        root = i;
        memset(vis,0,sizeof(vis));
        solve(root);
        int t = max(dp[root][0],dp[root][1]);
        printf("%d\n",t);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44694282/article/details/93528157
今日推荐