HDU 1020(Encoding)

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/86611389
                                                Encoding
          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                        Total Submission(s): 57794    Accepted Submission(s): 25803

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    int n,b[26]={0},i,count=1;
    char a[10000],c;
    cin>>n;
    while(n--)
    {
        cin>>a;
        for(i=1;i<=strlen(a);i++)
        {
            if(a[i-1]==a[i])
                count++;
            else
            {
                if(count==1)
                    cout<<a[i-1];
                if(count>1)
                {
                    cout<<count<<a[i-1]; 
                }
                count=1; 
            }
        }
        cout<<endl;
        count=1;
    }
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/86611389