#HDU 2594 Simpsons’ Hidden Talents (KMP)

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

 

clinton homer riemann marjorie

Sample Output

 

0 rie 3

题目大意 : 输入两个字符串 ,输出第一个字符串的前缀与第二个字符串的后缀相同的最大长度。

思路 : 比较前缀后缀的长度, 很显然是KMP, 不过这道题两个字符串是分开的, 所以我们只要将他们拼接起来就OK了。 但是 还有一个问题,你拼接后, 万一循环体的长度大于你原先的字符串怎么办? 比如 第一个字符串 输入 “ababab”, 第二个输

出“ab”, 答案应该是输出 ab 2, 可是你你拼起来后, 最大长度就成了6, 可以自己敲一下试试, 而6是明显大于第二个串的, 所以我们就要分情况讨论, 一种是没有匹配的,也就是nxt末尾 == 0, 这时候直接输出0即可, 第二种情况, 就是我刚才说的, 拼接后字符串的长度大于其中一个字符串长度, 说明一定有一个字符串他本身就是前缀 or 后缀, 所以输出长度较小的那个就OK, 第三种情况, 拼接后的长度比原先两个字符串长度都大, 这时候用substr输出前缀就行, 思路还是很清晰的!注意多样例的初始化哦

AC代码 :

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
const int maxn = 1e6 + 5;

string a, b, c = "";
int nxt[maxn], len1, len2, len_;
void getnext() {
    nxt[0] = -1;
    int i = 0, j = -1;
    while (i < len_) {
        if (j == -1 || c[i] == c[j])
            nxt[++i] = ++j;
        else
            j = nxt[j];
    }
}

int main()
{
    while (cin >> a >> b) {
        memset(nxt, 0, sizeof(nxt));
        c = "";
        len1 = a.size(), len2 = b.size();
        c+= a, c+= b;
        len_ = c.size();
        getnext();
        int temp = nxt[len_];
        if (!temp) {cout << 0 << endl; continue;}
        if (temp > len1 || temp > len2) {
            if (len1 <= len2) cout << a << " " << len1 << endl;
            else cout << b << " " << len2 << endl;
        }
        else cout << c.substr(0, temp) << " " << temp << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43851525/article/details/91862543
今日推荐