hdu2594 Simpsons’ Hidden Talents(KMP)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3594    Accepted Submission(s): 1336


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
 
  
clinton homer riemann marjorie
 

Sample Output
 
  
0 rie 3
 

Source
HDU 2010-05 Programming Contest  
/*
尼玛,此题好邪门。。。考虑两个字符串接到一块得到的公共比其中任意一个的小,比较一次有可能还比其中的一个大,while循环一直比较。。。
加油!!!
Time:2015-4-13 11:57
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=50000+10;
int nxt[MAX<<1],len;
char str1[MAX<<1],str2[MAX];
void Get_next(){
    int i,j;
    i=0;j=-1;
    nxt[0]=-1;
    while(i<len){
        if(j==-1||str1[i]==str1[j]){
            i++;j++;
            nxt[i]=j;
        }else
            j=nxt[j];
    }
}
int main(){
    while(scanf("%s%s",str1,str2)!=EOF){
        int len1=strlen(str1);
        int len2=strlen(str2);
        strcat(str1,str2);
        len=len1+len2;
        Get_next();
        if(nxt[len]==0){puts("0");continue;}
        int res=nxt[len];
        while(res>len1||res>len2){
                res=nxt[res];
        }
        for(int i=0;i<res;i++){
            printf("%c",str1[i]);
        }printf(" %d\n",res);
        /*for(int i=0;i<=len;i++){
            printf("%d %d %d\n",i,nxt[i],i-nxt[i]);
        }puts("");*/
    }
return 0;
}

猜你喜欢

转载自blog.csdn.net/u013634213/article/details/45023883
今日推荐