HDU 2594 Simpsons’ Hidden Talents KMP

题目:

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

思路:

现将两个字符串a和b拼接起来,然后利用KMP求这个表的前缀表,判断p[lena+lenb]是否大于两个字符串的长度,如果大于则回溯,直到不大于为止。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=1*1e5+5;
char a[maxn],b[maxn];
int lena,lenb;
int p[maxn];
void prefix_table()
{
    int i=0,j=-1;
    p[0]=-1;
    while (i<=lena+lenb)
    {
        if(j==-1||a[i]==a[j])
        {
            p[++i]=++j;
        }
        else
        {
            j=p[j];
        }
    }
}
int main()
{
    while (scanf("%s%s",a,b)!=EOF)
    {
        lena=strlen(a);
        lenb=strlen(b);
        strcat(a,b);
        prefix_table();
        int t=p[lena+lenb];
        while (t>lena||t>lenb)
            t=p[t];
        if(t==0)
        {
            printf("0\n");
        }
        else
        {
            for (int i=0;i<t;i++)
                printf("%c",a[i]);
            printf(" %d\n",t);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/86577526
今日推荐