HDU-2594-Simpsons’ Hidden Talents (kmp)

                                          Simpsons’ Hidden Talents
 


Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意描述:

输入a,b两个串求a的前缀与b串的后缀相同的部分

程序代码:

#include<stdio.h>
#include<string.h>
void get_next(char *s);
int kmp(char *s1,char *s2);
int next[50010];
char a[50010],b[50010];
int main()
{
	int t;
	while(scanf("%s%s",a,b)!=EOF)
	{
		t=kmp(b,a);
		if(t==0)
			printf("0\n");
		else
			printf("%s %d\n",b+(strlen(b)-t),t);
	}
	return 0;
}
void get_next(char *s)
{
	int i,j,lens;
	i=1;j=0;next[0]=0;
	lens=strlen(s);
	while(i<lens)
	{
		if(j==0&&s[i]!=s[j])
		{
			next[i]=0;
			i++;
		}
		else if(j>0&&s[i]!=s[j])
			j=next[j-1];
		else
		{
			next[i]=j+1;
			i++;
			j++;
		}
	}
}	
int kmp(char *s1,char *s2)
{
	int i,j,lens1;
	get_next(s2);
	i=0;j=0;
	lens1=strlen(s1);
	while(i<lens1)
	{
		if(j==0&&s1[i]!=s2[j])
			i++;
		else if(j>0&&s1[i]!=s2[j])
			j=next[j-1];
		else 
		{
			i++;
			j++;
		}
	}
	return j;
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81168536
今日推荐