c An easy problem

Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output
19
18
10
-17
-14
-4

#include<stdio.h>
void main()
{
    int n,i,b;
    char a;
    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++){
			getchar();
		    scanf("%c %d",&a,&b);
			if(a>='a'&&a<='z'){
			    b-= a - 'a' + 1;
			}else if(a>='A'&&a<='Z'){
			    b+= a - 'A' + 1;
			}
			printf("%d\n",b);
		}
    }
}


猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/88343638