FZU2214 Knapsack problem

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/89605936

Problem 2214 Knapsack problem

Accept: 1131    Submit: 4313
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

1 5 15 12 4 2 2 1 1 4 10 1 2

 Sample Output

15

#include<iostream>
#include<cstring>
using namespace std;
long long int dp[2500009];
long long int w[509],val[509];
int  main(void){
 	 int T;
	 scanf("%d",&T);
 	 long long int sum =0;
	  while(T--){
	  int n;
	  long long int m;
	  scanf("%d",&n);
	  scanf("%lld",&m);
	  sum=0;
	  for( int i=0;i<n;i++){
	  	   scanf("%lld%lld",&w[i],&val[i] );
	  	   sum+=val[i];
	  }
	  memset(dp,0x3f3f3f3f,sizeof(dp));
	  dp[0]  = 0;
	  for( int i=0;i<n;i++){
	  	  for( long long int j=sum;j>=val[i];j--){
	  	  	   dp[j] = min(dp[j],dp[j-val[i]]+w[i]); 
			}
	  }
	  
	  for( int j=sum;j>=0;j--){
	  	   if( dp[j] <= m ){
	  	   	    printf("%d\n",j);
	  	   	    break;
			 }
	  }
	  
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/89605936
今日推荐