FZU 2214 Knapsack problem(01背包+思维)

版权声明:本文为博主原创文章,欢迎转载。如有问题,欢迎指正。 https://blog.csdn.net/weixin_42172261/article/details/89630879

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).
Input
The first line contains the integer T indicating to the number of test cases.
For each test case, the first line contains the integers n and B.
Following n lines provide the information of each item.
The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.
1 <= number of test cases <= 100
1 <= n <= 500
1 <= B, w[i] <= 1000000000
1 <= v[1]+v[2]+…+v[n] <= 5000
All the inputs are integers.
Output
For each test case, output the maximum value.
Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2
Sample Output
15

看完题就会想到开一个二维数组来存数据,但是数组一行的列数是由B来决定的,B很大啊,这样二维数组就开不下了。换个思路,以价值为背包,最后求出在最大的价值下装入的重量最小(必须小到比B还小就行了)。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int inf=0x3f3f3f3f;
int dp[5005];
int w[505], v[505];
int main()
{
	int t, n, m;
	scanf("%d", &t);
	while (t--){
		int sum=0, ans=0;
		memset(dp, inf, sizeof(dp));
		scanf("%d%d", &n, &m);
		for (int i=1; i<=n; i++){
			scanf("%d%d", &w[i], &v[i]);
			sum+=v[i];
		}
		dp[0]=0;
		for (int i=1; i<=n; i++){
			for (int j=sum; j>=v[i]; j--){
				dp[j]=min(dp[j], dp[j-v[i]]+w[i]);
			}
		}
		for (int i=sum; i>=1; i--){
			if (dp[i]<=m){
				ans=i;
				break;
			}
		}
		printf("%d\n", ans);
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42172261/article/details/89630879