FZU - 2214 Knapsack problem

FZU - 2214 Knapsack problem

01背包

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input
The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+…+v[n] <= 5000

All the inputs are integers.

Output
For each test case, output the maximum value.

Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2
Sample Output
15

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm> 
#include<cstring>
#include<string>
#define N 510
#define INF 0x3f3f3f3f
using namespace std; 
int wei[N];
int val[N];
int f[10010];
int main()
{
    int i,j,n,m,t;
    int sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        memset(f,INF,sizeof(f));
        f[0]=0;
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++){
            scanf("%d%d",&wei[i],&val[i]);
            sum+=val[i];            
        }

        for(i=0;i<n;i++)
        {
            for(j=sum;j>=val[i];j--)
                f[j]=min(f[j],f[j-val[i]]+wei[i]);
        }
        for(j=sum;j>=0;j--){
            if(f[j]<=m){
                printf("%d\n",j);
                break;
            }
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mandiheyanyu/article/details/82430069
今日推荐