PATA1065 A+B and C (64bit)

版权声明:版权归原作者CangyeChen所有,未经原作者允许不得转载本文内容,否则将视为侵权,转载或者引用本文内容请注明来源及原作者,对于不遵守此声明或者其他违法使用本文内容者,本人依法保留追究权等 https://blog.csdn.net/CANGYE0504/article/details/88908752

1065 A+B and C (64bit)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include <cstdio> 
   
int main(){ 
    int n,i; 
    long long int a,b,c; 
   
    scanf("%d",&n); 
    for(i=1;i<=n;++i){ 
        bool flg = true; 
        scanf("%lld %lld %lld",&a,&b,&c); 
        long long res = a+b; 
        if(a>0 && b>0 && res<=0)flg = true; 
        else if(a<0 && b<0 && res>=0)flg = false; 
        else{ 
            if(res<=c)flg = false; 
        } 
        if(flg){ 
            printf("Case #%d: true\n",i); 
        }else{ 
            printf("Case #%d: false\n",i); 
        } 
    } 
    return 0; 
}

猜你喜欢

转载自blog.csdn.net/CANGYE0504/article/details/88908752